App installation failure

App installation failed with error message: error 0x80070490: Opening the package from location Mylio_x64.msix failed. (0x80070490)

I just tried applying the latest update and received this message. Has anyone else experienced this?

This is a common Windows Update error. There are three things you can try:

a) Reboot the Windows device. 90% of the time this is just a stuck update that needs to have a reboot. Then try the update again.

b) Install Mylio from the website instead of doing the Update:

Download Mylio for Windows, Mac, iOS and Android

c) Download the Mylio binaries and double-click it to install directly:

For Intel CPU (Most common):
https://myliodownloads.s3.amazonaws.com/Mylio_x64.msix

-or-

For ARM CPU (e.g. Microsoft Surface Pro X):
https://myliodownloads.s3.amazonaws.com/Mylio_arm64.msix

If you use step (b) or (c) you will need to remove the older version of Mylio (3.16) manually from Add/Remove programs. Otherwise you will end up with two shortcuts but only 1 will work.

If you can reply back with which you tried and what worked for you, Iā€™d appreciate it. Thanks!

2 Likes

Thank you so much for the prompt and useful reply! I had already tried a) and it failed. When I tried b) it produced the same error regarding the .msix packaged. Approach c) worked perfectly.

Keep up the great work.

Dennis

1 Like