BUG: Cannot share from Photos to Mylio on iOS after recent update

I am now having a problem using the share option from Photos to Mylio on my iPhone 6s iOS 13, latest Mylio version. I share a photo from Photos (have been doing this with no problem), open Mylio to receive it into the Inbox and an error is displayed. Tried the same photo twice, now two errors, tried a photo I successfully transferred a few days ago and now three errors.

Has this update broken something in sharing from Photos to Mylio (not linked, just manually shared)? And in the meantime what can I do to get rid of the errors coming up every time I open Mylio ie to tell it to forget that I shared them…

Hi @mpitman - thanks for letting us know this is happening. Can you please share what the error message says?

Additionally, we have a version of Mylio containing a few bug fixes coming out soon which may fix this issue. I can’t reproduce this problem but I’m both on iOS14 and running this new version, so I’m not positive which one of these differences fixes the issue yet.

Thanks for getting back quickly on this. As you can see the errors are fairly nondescript, and the ‘following files’ are not named anywhere. Every time I open Mylio it keeps trying to import the same files. If I send another one, it will just add to the number of failed files.

This is very frustrating as I really really like what Mylio has to offer and what to commit heavily to it, but keep hitting things like this and also Mylio hngs trying to find preview/original on vault, which end up taking up a lot of time to solve what should be avoidable problems.

Looking forward to a solution soon.

PS A little disappointed that you don’t have a way to test one version back from current (and very recently released) iOS. Updating now to ios14 and will report back on whether that resolves it for me.

The upgrade to iOS 14.0.1 has not solved the problem. I’m wondering if this is because of the existing error. Is there a way I can tell Mylio to forget those photos it is still trying to import?

My partner’s phone is still on iOS13 and updated to the latest Mylio yesterday. I’ve just tried sharing from Photos to Mylio and it worked fine there - same phone, iOS as mine so looking like a different issues. It seems possible that the problem arose because of the specific photo I tried to share (old one sent to me by a friend). If so this will be the second time a specific photo has caused issues (see other issue mentioned in earlier reply).

If you can advise how I can tell Mylio to forgot the photos I can retest using a more likely successful photo to see if it is the specific one.

So… I decide to hit this with the big hammer and removed my iPhone device and started again. The 3 photos that were stuck were imported. I deleted them (as I didn’t really want them :-)) and tried to move the one that first caused the problem. It moved fine. So… no idea what went wrong here, but resetting a device isn’t something I would like to do this often…

Seems like a glitchy thing that will be hard to track down.

Hi @mpitman - Thanks for the update and I’m happy to hear you were able to resolve this, albeit with “the big hammer”. Sorry it came to that. Going forward please feel free to contact our support team directly (support@mylio.com) and we can work with our engineers to discover a bit more about this issue and find a more viable solution - I know it is quite a pain to reload the app and get set back up.

Oh, and just a follow-up: our team definitely has the resources to test all kinds of iOS versions against all kinds of Mylio versions. I was just doing some ad-hoc troubleshooting on my equipment and hadn’t sent this to our test team yet :slight_smile:

Hi Matt

Thanks so much for getting back to me again on this. At this stage I have only a limited number of photos involved as I’m still gaining confidence to extend more (and have had a couple of confidence shakers on the way). So the ‘big hammer’ wasn’t too bad, solved the immediate problem, and demonstrated that it was a quirk rather than a general problem. But yes, if I’m further down the road I’ll definitely look for a better way!

Thanks also for the clarification that you were just doing a quick check and that the team has resources to test across multiple versions.

Hmmm I’ve just updated the iPhone to the lastest update and the problem has recurred. It was fine after I had reset the device previously. This is getting really annoying :frowning:

Hi @mpitman - thanks for letting me know. I agree, that is super annoying. Can you please do me a favor and submit logs from the iPhone to our support team so we can see why this is happening? You can do this by…

  1. Open Mylio on your iPhone
  2. Tap the three dots in the top right corner
  3. Tap Help
  4. Tap “Contact Mylio Support”
  5. In the subject, please briefly describe the issue - something like “Sharing to Mylio broken”
  6. In the body, please put “discussed on forum”
  7. Select “Upload”
  8. Wait a few minutes with Mylio open while we upload the logs from your device.

I’ll work with our support team to figure out why this is happening and we’ll find a solution for you.

Sorry again for the inconvenience.

Thanks Matt. Logs have been sent.