'Free Up Space' doesn't work (Samsung S9)

Hello Everyone,
The ‘Free Up Space’ feature stopped working properly on my mobile.
I use Galaxy S9.
It worked perfectly until last month.
I just press it and it doesn’t work even if I let it go for hours.
Is there anyone who had same problem? How did you solve it?

Did it work for you on the Galaxy S9 previously?

Yes
It worked great on this specific phone.

I have this same issue on my personal phone (also Galaxy S9). It’s not completely fixed, but it should no longer hang in Mylio 3.15 7308 (Released April 29). Current behavior that I am observing is that most files are not cleaned up, but a small number are.

We’ll keep working on this. Hopefully should be fixed in the next release, but I can’t guarantee that. Let me know if you see different behavior.

Hi @Mylio_Tim !
Thanks for that!
I have made tests today and it seems like it only deletes 1 file every time I use this feature, I don’t know about the size but all my files there are small. Only jpg and most of them are under 500 KB.
I’m glad to hear that you are working on it, this bug is frustrating.
Thanks !

My personal phone is also experiencing this, so I feel your pain.