Help! Adding metadata externally via a added XMP sidecar file doesn't seem to work

In my Mylio library I have an PSD file named Winter sun in Katoomba_collage.psd which has nearly no metadata saved in it. However its source photo named Winter sun in Katoomba_IMG_9814.jpg has lots of Metadata.

So via exiftool I created from Winter sun in Katoomba_IMG_9814.jpg a sidecar XMP file, named it Winter sun in Katoomba_collage.xmp and put it next to the PSD.

I was hoping this would give the PSD the needed metadata, but what happened? The XMP got silently deleted by Mylio!!! How can I add a XMP to a file which does not have a XMP yet?


ps: An additional strange thing is that I can add metadata to the PSD in Mylio (e,g, via rating or flagging). These metadata are persistent, but are not saved to a XMP sidecar file and are not saved in the PSD either. Where the heck are they saved???

Send me a support request and I’ll take a quick look. (Actually, strike that, I realized you said PSD).

A .psd file is considered a document file inside Mylio, rather than a photo file which comes from a camera. So we actually don’t write metadata to the XMP for those. (And we also don’t support edits for it.)

If you rate documents, the ratings etc. is kept inside the Mylio catalog only - not in the sidecar file. You’d have to update that through Mylio. How many of these do you have?

That explains it, thanks for chiming in so promptly.

But why is a PSD a dcouemnt and not an image format for you?

I reckon I might keep then in Mylio only TIFF exports from my PSDs and then keep the PSDs separately.

Update: I tried with a TIFF and the metadata is still not updated - have send a support request.

In short, because it’s not a camera produced format. We need to do a better job when it comes to non-camera support files like PhotoShop, DXO etc.

You’ll notice the .psd also can’t be paired with a camera raw file on the same picture - Mylio will split it and show it as 2 tiles (where one will show with a -1 filename).

1 Like

It works with TIFF files. Just be sure you’re using EXIFTOOL to update the XMP sidecar file, not the image file. Mylio reads the metadata from the XMP file. I just tested this successfully with a TIFF image - made an update to the XMP file’s metadata in ExifTool, and the change immediately showed up in Mylio (it’s in a Source Folder).

I stopped using PSD files in Photoshop a long time ago. TIFF files can save all the Photoshop layers just the same as PSD, and are far more compatible with other image-editing apps.

Strange, doesn’t work for me. What comamnd line options do you use with exiftool?

I use:

exiftool -tagsFromFile orig_image.jpg edited_image.xmp

where edited_image.tiff is the photo I want to give the metadat from orig_image.jpg.

We may be trying different things. I was using exiftool to alter metadata in an existing XMP file for a TIF image that was already in Mylio.

Sounds like you may be trying to create a new XMP file for a TIF, prior to importing it into Mylio. Is that right?

@jimre Yes, we seem to do slightly different things: We both have the image already in Mylio, but mine has not yet an XMP.