Manually added GPS data gets corrupted in database

I have a serious bug to report, which makes manually added GPS coordinates corrupted/invalid.
It was recognised by my father and we analysed it together.

We add GPS tags to our photos. Most photos are from a finite list of places (also from scanned old photos), we use a list of locations with the gps coordinates from Google Maps.
After we select the photos (one or more), we copy the coordinates to the “GPS Coordinates” field on the “Info” tab.
I also used the Map tab to drag and drop photos.
List in Excel:

The problem is, that after some undefined time the Longitude value (second) looses the decimal places (gets rounded to the integer value) and so corruptes the coordinates.
The real problem is, it doesn’t happen instantly, but my father did use the Excel list method since this week.

I don’t know if it happens to all photos or only some. I also don’t know since which version it behaves so, 3.7 or 3.8.

Unfortunately, this means that assigning GPS coordinates is not safe at the moment.
kép

I can send support request with data, if needed for analysis.

What is the set of devices on your account? (PC/MAC/Android/iOS etc.)

Pc and Android on both setups.
Having a Google Drive as cloud backup.
I also have external hdd and nas backup.

Editing of gps data is only done on Windows.

I have a manually initialized backup of all my sidecar files (batch file copy + compress). The last one was done on 2020.04.04 20:45. There the coordinates I have checked are still alright.

Out of curiosity I also checked some files that I haven’t edited in the last weeks.
This screenshot shows the xmp sidecar and the display of a photo.
The coordinate in the file is still intact, but it gets displayed false.

I thought about what I could have done to my files because I do things with other tools on my files.
But the system of my father is independent of mine (we only introduced the Google Drive backup and my computer as second system this week ). He only uses Mylio for the files.

Do you have some news on this issue or do you need further data for analysis?

After seeing your report and one other from another user, we do have a repro of this bug on our end as of last night and are still investigating fixes. Thanks for reporting this.

1 Like

The main bug is solved with the last update. New data entered via the UI is not corrupted anymore. Thank you!

On the other hand, there are files where the data in the XMP is correct, but the data in the database was corrupted.
So I ask @Mylio_Michael, @Mylio_Deon, if there is a way to force Mylio reread the XMP files and rebuild/update its database with the data from there?
It would be great, if I could let Mylio try to clean up the messed data and I only had to care about the mess, where the XMP is corrupted.

“touch”-ing the file should be sufficient to have Mylio rescan it. (i.e. Changing the date on the xmp file).

How familiar are you with OSX Terminal? If you’re very comfortable there, you can try running something like the following in the folder where you want your XMPs to be rescanned:

find . -type f -name “*.xmp” -exec touch {} +

Thank you!
I am on Windows and it has no touch function, but Total Commander has a similar functionality and it worked out for a set of testfiles.

2 Likes

I think I might be the other user who reported this issue directly to the support team.
I have updated to the latest version and it appears any new photos added to the library now show as the correct location on the map.
If I manually move the location of a photo to the proper location then it does retain the changes so it looks like this issue may be resolved.

I’m also on a windows machine and being able to force Mylio to “rescan” all my 100k photos again to get the proper GPS location would be great!
At the moment I am using file explorer to copy a folder out to a separate location… Delete the folder in mylio… Wait for the delete to propogate everywhere and then copy my folder back into the main Mylio location so that the photos are re-scanned into the library…

This is very slow so a faster way would be great :wink:

A lot of my photos do not have a matching XMP file though…

1 Like

Hi and welcome to the forum,

I can describe you the way I was forcing the rescan.

I use Total Commander for a very long time. It is a very powerful file manager with roots on Windows 3.1 (or even older).
It is a shareware and is totally functional if downloaded and installed from here.
There are surely other similar file manager with similar functionalities.

After installing, navigate one panel to the root folder of your photos or a folder with photos, also containing subfolder is possible.

  1. Use Alt+F7 to open the search dialog. Here enter the pattern for the file name (e.g. *.xmp) and uncheck to look in compressed files. Start search by hitting Enter or with the button top right.
  2. After that, you have a list of files in the search window. In the botton row 2nd from right is “to window” or something similar (I use it in Hungarian), which brings this list with filename and path to the original panel.
  3. Here you select the files with * (asterix or “star”) on the numerical keyboard. Alternatively you can use the second menu “Selection”. This marks turns the marking of the files (when nothing was marked as default, it selects all files).
  4. Choose “File - Change attributes” (first menu item). Here you check the checkbox for changing date and time, there is a button for current and hit OK.
    This changes the file modification date to the one set in the dialog.
    Depending on the number of files and type of drive (hdd or ssd) this can take some seconds up to a minute or so.
  5. Mylio should recognize these changes, but you can force it with “Organize - Scan for changes”. It can take also some time until all the files are read and synchronized.

This is pretty much the functionality of touch, but without the command line (and Win10 doesn’t have touch by default).

Which file types do you have?
Mylio saves every change you made inside Mylio to the XMP sidecar files for every filetype.
Other programs might save changes to the JPG, DNG and TIFF files themselves (there might be other extensions, too). Most programs don’t touch RAW files (like CR2, NEF, ORF).

If you have smartphone photos (usually JPG) with GPS data with wrong display in Mylio, you might have to change the timestamp of those files, too. Reading these files takes considerable more time, then only the small XMP sidecars (but still much less, then your original process).

If you used also “Photo - Save metadata to file” in Mylio,then you have to change the timestamp of those files too.

My assumption is, that only data got corrupted, where the UI was active on the file or folder since 3.8, but using the Map view or Map tab on a folder can show you, if they are in the correct position.

Zoltán

Edit: I used this on my main computer which is configured as a vault. I guess you should use it on the original files, but if they are on an external drive, I don’t know how Mylio reacts for changes on those files, I have no experience.

1 Like

Hello, I have similar problems with the GPS data in Mylio. Most all photos have a position about 50 - 100 km west of where the photo was really taken. Most of the photos have been tagged using Lightroom, but also the photos taken with my Android phone appear at a false location.

. In lightroom, google maps, android etc, the location is good. But in Mylio its way off. Hope this info helps.

Hello and welcome to the forum,

If you select a photo in folder/calendar/all photos view and navigate to the end of the info tab, there are the GPS coordinates of the photo. You will probably see the second value rounded down.

Smartphone photos are either JPG or DNG and Lightroom writes these information to the files themselves.
I suggest you to duplicate some photos to Mylio (not copying inside) to a folder and check if the newly imported files still have the correct coordinates (should, if you haven’t written metadata to the files).

Then you would have to tell Mylio to update the files (reread data from the files).
You haven’t mentioned if you are on Windows or Mac, but in the previous post there are solutions for both systems.

Mylio has already read the wrong data to the database and is only going to reread the data, if the files change. But it is enought to change the timestamp of the file, doable from command line on Mac or 3rd party tools in Windows.

1 Like

Ok, thanks for the feedback. After several re-installs and refreshes I got the GPS-coordinates right. :grinning: Except for 1 photo. So I altered that one manually. Still strange. All Photos had only 1 digit for the second GPS coordinate, so all were moved way to the left on the map.
It would be useful if Mylio had some type of ‘refresh’ functionality where all metadata would have been refreshed.

I have used the Total Commander file tool to change the “Modified” date of ALL my jpg and xmp files and then let Mylio rescan everything.

I still have thousands where the precision of the GPS co-oridinates appear lost.

Any help from the community or the Mylio team would be appreciated as this is proving very frustrating…

image

The solution with Total Commander / touch works only, when the data in the files is still correct, “only” the Mylio database got corrupted.
You have to use external tools like Exiftool or for example XnViewMP to check if the files still have the correct coordinates.

If you have RAW files and they have the GPS coordinates, those values were surely not touched by Mylio. Setting the date on these files will correct the database.

If you have JPG/TIFF files, they can be written by Mylio, but you have to do it (Photo - Save metadata to file). If you did it after the database got corrupted, the your values in the files are also corrupted. Here you will have to correct the data manually.

If you haven’t written the data back to the JPG/TIFF files, they still can contain data (e.g. when a smart phone has tagged them at creation). Mylio imports this data to the database and writes it parallel to the XMP sidecar files. So if the XMP file contains wrong data, but the JPG/TIFF still has the correct values, the “touch” of the JPG/TIFF files (and leaving the XMP files at original date) should advise Mylio to reimport the data.

If the data in the files is incorrect, your only chance is to correct them manually.
I don’t see other possibilities to correct a corrupted database.

The GPS data in the Exif of my files is still correct. If I view the photos using another tool I can see that the GPS location is still correct.

How do I completely reset the Mylio database so it just rescans all my photos?

V1: modify the date of all your jpg files, leave the XMP as is.
This should advise Mylio to Update the database with the data from the files.

V1b: V1, but delete gps information in Mylio before manually.

V2: copy the jpg files to another location outside Mylio without the XMP files.
Delete all files inside Mylio.
Import the files again.
Warning: with V2 you loose every data you entered inside Mylio, they are stored ín the XMP files.

Thanks… If I delete the GPS info from within Mylio will that not update the jpg file and then I’ve lost the co0oridnates forever?

Mylio by default only writes to the XMP file, also in the case of a jpg file.
It only writes to the jpg when you select a file and execute “Photo - Write metadata to file”.
Edit: otherwise jpg files are untouched.

You can check this by importing photos into Mylio and checking the file dates after changing data.

This is a non standard behaviour, I assume for performance reasons.