Moving Folder on Disk

I am currently experiencing the continuing “Moving Folder On Disk”.

I have only one client open, an iMac, with a Google Drive and NAS vault attached.

I have tried the troubleshooting thing with the orphans commands, but it keeps doing it.

Any good ideas to get it to stop?

Thanks

In Mylio, moving folders or files is considered the highest priority task, because they are directly tied to where the files are stored in the file system. Open Mylio’s Console from the Help menu. There are 2 console commands you can try after. Enter the commands one at a time. After entering one, hit enter/return on your keyboard and Mylio will show you search results below the console window similar to if you were to use the search bar normally in the app. If the first does not show anything, run the second. Here are the commands:

showmoves folder

showmoves media

If something does come up in the search results for either showmoves folder or showmoves media, you can use the Mylio Clipboard to help Mylio move them. Information about the Mylio Clipboard can be found on our Support Site here:

showmoves folder shows 0 folders to move
showmoves media shows 0 media to move

And it keeps doing “moving folder on disk”

This maybe a folder on the NAS. Try:

showmoves <NasName> folder

So e.g.

showmoves MyNas folder

If the name of your NAS has a space in it, you can either rename it, or use the identifier instead. To get the list of identifiers, run:

devices

This will output e.g.

Id       Name                       Type              Where         
=======  =========================  ================  ============= 
      0  Mylio Cloud                Cloud Services                  
      1  Home PC                    PC                              
      2  Office PC                  PC                              
6094851  MyNAS                      NAS                             

Then you can use the identifier, e.g. 6094851 in this case, by prefixing it with device_. E.g.

showmoves device_6094851 folder

And then same thing for media.

I eventually worked it out. Using showmoves folder multiple times, an empty folder showed up, that apparently no longer existed in the file system, could not show it in Finder. I deleted the folder, and that seemed to solve it. Everything is fine again.

2 Likes

I have now the same issue, open also a ticket, but the upload was not finished completely, as my Mylio goes a bit nuts with some folders I just deleted. I removed them now from the hard disk and on the Vault and Mylio still goes crazy with this Move Folders dialog.
image

This folder does not exist any more:

Try searching for that folder name using search, then either move it somewhere else, or delete it.