Mylio doesn`t pick up updated geotagged photos

I have updated some photos with new geolocation - new coordinates. I have done this in Imatch. Mylio doesn`t seem to pick up the changes. Why? I have written the data back to files in Imatch, so I thought Mylio should see this?

Mylio generally seems to detect changes written to XMP sidecar files pretty quickly. For metadata embededded within the image file, you probably have to use the Organize -> Scan for Changes command on the selected folder or file. That may take a while, depending on what was selected.

Ok. Strange. I waited several minutes and did what you described here. But nothing happened. I had to manually move them on the map in Mylio.

I have discovered one more thing that happens sometimes:

When zoomed out it seems like all photos from a folder is right on the map. But when zooming in, several groups of photos are totally wrong on map. Why? The strange thing is that for the folders I checked now, it seems to be right on map in Imatch, but not in Mylio. When groups of photos are wrong placed on map, there is no possibility in Mylio to see which photos this is. Frustrating.

Does IMatch write to the XMP file or the image? I just edited the latitude and longitude in an XMP file using a text editor, and Mylio noticed the change without delay - though I had to move the selection off the image and back again to make it show in the Info pane.

In Imatch:
GPS Latitude: {File.MD.XMP::exif\GPSLatitude\GPSLatitude\0}
GPS Longitude: {File.MD.XMP::exif\GPSLongitude\GPSLongitude\0}
GPS Position: {File.MD.Composite\Exif-GPSPosition\GPSPosition\0}

Does this make sense?

I also checked in Imatch that everything seems to be written back to files.

Yes, but which files? If your images are raw, it will likely be the XMP file - but if they are JPEG, it will probably write the data there, and Mylio may not notice that.

I don’t have IMatch, so I don’t know about the field names.

In these examples it was jpg and heic files. But as long as I write the changes to files in Imatch, Mylio should read that?

Once the image has been imported to Mylio, I think you would need to be sure IMatch was writing to the corresponding XMP file, and not the JPEG.

Thank you. There is a setting in Imatch I have to find perhaps. I will check this out.

It definitely sounds like a compatibility issue between Mylio and iMatch. This scenario works just fine with Mylio and Lightroom Classic:

  1. Photo already exists in both LR and Mylio.
  2. In LR, drag photo onto Map to set GPS location.
  3. In LR, select photo and choose Metadata -> Save Metadata to File.
  4. In Mylio - observe that GPS location shows up automatically, within a few seconds (noted by appearance of “pin” annotation in grid view).

I tested this with RAW files, haven’t tried JPEG or HEIC yet.

EDIT: I should note that my top-level Lightroom folder is a Source Folder in Mylio, which may explain why the changes are picked up right away in Mylio.

Possibly a rounding error when the iMatch GPS coordinates are read by Mylio?

I also tested with raw files now and Mylio seems to pick up that. But not for jpeg or heic files as far as I can see? In Imatch I think the metadata for jpegs is stored in the files when data is written to files. Shouldn`t Mylio see this?

Tried this with JPEG files - and here Mylio seems to be quite unpredictable. Or at least I can’t figure out its exact behavior. Sometimes you have to do Scan for Changes (and wait) for the external GPS changes to show up. Sometimes you have to actually “touch” the file (eg, change its File Modified Date) before Mylio notices. Sometimes you have to RESTART Mylio before the changes are picked up. And sometimes the changes never seems to get picked up at all. Frustrating.

I’ve added a Feature Request to replace the unpredictable Scan for Changes command with a predictable Read Metadata from File command instead:

Replace “Scan for Changes” with “Read Metadata from File” - Feature Requests - Mylio Community

Thanks jimre. Imatch administrator says:

“When you write back metadata, all metadata is stored in the JPEG file, including the GPS information, EXIF, XMP. It automatically becomes visible in all other applications. No need to do anything special.”

So why shouldnt Mylio be able to read this? I think we agree that this has to be fixed? Or are we missing a setting in Mylio? I just dont understand why this will not work.

Mylio is XMP-based. It prefers to use XMP sidecar files for ALL photos, not just RAW. While this makes Mylio internally consistent (and probably much faster for syncing & updating) - this is different from many other editors such as Lightroom and iMatch. These apps prefer to store metadata embedded within the original file whenever possible (usually everything except RAW).

Unfortuantely once a file is imported into Mylio, after that you have to “trick” Mylio into reading metadata from the original image file - eg, by using Scan for Changes, changing the File Modified Date, etc. And as I point out the Scan for Changes command can be pretty unpredictable.

Here the iMatch folks obviously mean “It automatically becomes visible in all other applications that behave like iMatch:slight_smile:

I made a test with a JPG file created in Paint (no metadata) and a photo from my wife’s IPhone (no GPS data recorded).
I marked the position in the Map panel in IMatch and assigned GPS data.
Files were in a folder indexed by IMatch and a subfolder of a Mylio source folder.
After writing back the data in IMatch (pencil icon), the changes were instantly visible in Mylio.

It was the case both as new files and also marking another position in Imatch and writing that back.

For JPG it was the case for the other direction too (Assign coordinates in Mylio, write back with “save metadata to files”, in IMatch I had to rescan the folder, but the changes were visible there too.

So generally, there should be no problem with the interaction of GPS coordinates for JPG files.

The case might be different for HEIC.
I don’t use that format, but one test shows, that there is a difference of handling this format in Mylio and IMatch.
I can see different coordinates on the same file in IMatch and Mylio, after writing back the files in both apps.

Here is an example:

This map is from Imatch and show location of 15 photos.

The same folder in Mylio shows:

Here you can see that 12 of 15 photos have wrong location. These are jpegs. As I said, I have written back to files in Imatch and scanned for changes in Mylio, but no result.

Had Mylio already created an XMP sidecar file for these particular JPEGs, when you performed this test? It seems Mylio doesn’t create the XMP file unless you do some type of edit on the JPEG photo. In my case I tested with newly-imported JPEG files for which Mylio had not yet created XMP sidecars. I wonder if Mylio works differently in these two cases?

No, there were no XMP sidecars.

So I added a Description in Mylio to all (JPG test) files (XMP file was created in Mylio) and executed “Save Metadata to files”.
Caption was visible in IMatch.
Then I assigned a new GPS data in IMatch, executed write back.
This change was not picked up by Mylio.
Then I assigned a new Title in IMatch, executed write back.
This change was instantly visible in Mylio, but Mylio still showed the incorrect GPS data.

So, dear Mylio:
There is definitely a bug. If a JPG file has XMP sidecar files, a new GPS coordinate in the JPG is ignored, although other data is updated.