Mylio only shows new folder but not the images inside

I have Mylio running on a VM in a NAS and I have setup as per Importing From a NAS - Mylio
Any new folders I add to the “Mylio Pictures” Folder are showing up in a scan but each of these is empty. I have left it for 1 week now scanning and while it pulls in photos from my phone, all these new folders are blank.

I’ve tried restarting Mylio, manually rescanning those folders and some console commands to rescan.

Any tips on getting these scanned and loaded?

What type of images are in those folders? (E.g. JPG/TIFF/DNG etc.)

Hi Deon, here is a screenshot from the VM Mylio Client with it requesting Originals of the new folders. The count in the library hasn’t changed to pickup any of the images within these folders.

I originally added two folders as a test 1. JPG Sync Test & 2. RAW RAF Sync Test as I wanted to test separating out the file types. I only put 5 images in these folders.

Below that is a screenshot of the file system, most of the folders contain just JPG. Though some contain RAW and one folder contains PDF’s which i’ve shown expanded.

!

@Mylio_Deon The folders are still not updating and Mylio has been running the whole time save for a couple of restarts to see if that would solve it. I also have installed the latest update that came out.

I notice that when I right click and open the folder in explorer the folder that opens is the local drive (which actually is just the empty folder with no files inside). Is there something i’m doing wrong to be able to direct Mylio to search the NAS?

I’d tried choosing importing/copy the folder but Mylio said it already existed.

Ok, for those following along at home I managed to start getting images to show up in the folders.
I’m not exactly sure what the cause was but I tried a few things and one or a combination of them kickstarted the process.

  1. I enabled SMB 3.0 Notications and enabled Large MTU:
    How to use SMB 3.0 in QTS 4.2 | QNAP

  2. In Windows 10 I also enabled CIFS/SMB 1.0 Support and removed password protected sharing
    Scan to Folder through SMB Scan is notworking in Windows 10 pro - Microsoft Community

So I got Mylio to scan for a bit and it ended up finding over 300,000 images. Something strange/concerning happended and at some point Mylio started to count DOWN and remove images (i could see thumbnails etc disappearing and now some folders are empty again).

While this was happening Mylio said “Applying file system changes” not sure what this is doing?
W10_VM

Example 24755 Images in one folder

W10_VM

Then moments later 247505

W10_VM

Lastly for some reason my NAS (Master Pictures) is showing over 100,000 ORIGINAL images that it is requesting, From what I can tell, these images are actually on the NAS when I open up explorer/finder and check the server.

Notification_Center

It actually seems like maybe something changed in how the NAS files are being generated from the last version as these missing originals are now being reported as on the VM and referenced from there.

The mylio console is now showing this constantly for every file it seems, overnight none of the thumb/preview/original numbers in the sync level have changed:

2021/03/06 07:14:28.156 5E4 OpenFileStreamError - file: D:\Mylio\Mylio Pictures\Picture Books (Albums)\Jasper’s 1st Year Book.pdf, mode: rb, initialOffset: 0, sharedwrite: 1, exclusive: 0, err: 2

2021/03/06 07:15:29.300 07C OpenFileStreamError - file: D:\Mylio\Mylio Pictures\Portfolio\DSCF0241.JPG, mode: rb, initialOffset: 0, sharedwrite: 1, exclusive: 0, err: 2

Any idea what it means? D: is the local Mulio folder.

I had a similar issue where adding new folder with photos after the initial sync would show empty folders only. This was done on a local drive as I was fed up with messing around with the NAS/OneDrive incompatibility. I was asked to send logs to the support team, sadly never heard back. Same as you never had a response.

Shame really. Such a great potential in this application including the features and UI. But the bugs really killed it off for me and I’m off looking for a suitable replacement. Haven’t found anything yet but hopefully something will show up on the horizon soon.

Sorry to hear about the Support experience. @Deon does what he can to reply here on the forum and I am sure feels bad he hasn’t gotten back in on this thread. From the looks of things you contacted supported last month and you had been emailing with one of our team members. They had replied back to your latest email with some answers and asking for the logs as you mentioned but we did not hear back from you. I’ve re-opened that case and asked the team member to follow back up. If you are still interested please reach out again and we will follow up.

Mylio is working ok for me now but it took maybe 8 weeks to scan and injest the 300,000 images in my library. This was 24/7 scanning with 99% CPU utilization. For comparison i’ve had other DAM’s scan my library in days with the same hardware.

Hi Michael

I have sent a report from the application but guess it didn’t get there. I have since reinstalled the OS on my machine so Mylio is gone for now, but I will give it one more shot when I have time. Can you confirm that the scenario below would be completely possible?

  • Create a local Mylio folder in an alternative folder on a permanently attached D drive.
  • Copy a small portion of my photo library into the folder for it to be scanned and face tagged.
  • Set up a NAS device as a backup location for all the photos in Original quality
  • Set up an OneDrive folder as a backup location for all the photos in Original quality
  • Once all of the above is completed and I verified the numbers, etc, I can start adding more folders in batches to the main location on the D drive?

Thanks

That scenario would not be 100% possible. Particularly using OneDrive in that format. We support adding OneDrive as a cloud service in-app but have seen issues when using the service to sync a Mylio folder in the filesystem.

If the D: drive is an internal drive then you can set the Mylio library folder to write to it via the advanced setting during setup or by relocating the library folder to the drive after setup. If your D: drive is an attached/external drive then we recommend adding it as a separate device that stores Originals via the Dashboard and keeping the library folder for the computer local (even if it is set to optimized/thumbnails). This allows for optimal performance, especially when scanning for changes/additions made in the library folder outside of the app.

Adding a NAS is a great option but it is synced like all other devices. The Mylio library folder on that device (or any other) is less of a backup that you can retrieve or roll back data from in a pinch and more of a device to be a 1:1 reflection of the media you have on your computer or other devices.

Adding more folders to the Mylio library via the filesystem is possible but they need to be placed inside an existing source folder. If you want the new folders to appear in the top-level of your folder view of the app then they must be added via the Settings->Source Folders option in-app.

Hi Michael

Couple of things to clarify in your answer as I am getting ready to get Mylio installed and move my photo library to it.

Noted about the OneDrive setup. I will leave it out of the equation for now and will enable it later. Can I assume that setting up OneDrive as a cloud service in-app lets you choose the ‘backup’ location within OneDrive, and also stores the face-recognition, tags, etc data?

D drive is an internal, permanently fixed drive, so it will contain the relocated Mylio library folder as per the advanced setup guide.

Regarding NAS. Can you please clarify? Less of a backup/roll-back device but more 1:1 reflection seems kind of contradicting to me. Isn’t a backup/roll-back supposed to be an exact 1:1 copy of the content that is being synced? What will not be stored on the NAS drive in this setup?

And for the last point, adding more folders, which has failed last time. So my library in its root folder is sorted into annual folders (e.g. 2019, 2020, 2021, etc) and each of these folders then consists monthly folders. There are also some additional folders for other photos (cars, business photos, etc). Those annual and additional folders all will sit within the Mylio library folder. But as 2022 comes, I will be adding a 2022 folder to that structure within Mylio library. Are you saying that it won’t work, and I will have to use the Source Folders function? Or is that only to be used when a folder is OUTSIDE of the Mylio library structure?

Thanks