Mylio quits with no explanation

Hi – I’m helping a niece get set up with Mylio. I use Mylio myself and get along well with it, but my niece’s installation has me flummoxed.

The problem is that Mylio quits without explanation about 10-15 seconds after launch. I don’t know how to debug this.

We have Mylio installed on a 2019 MacBook Air. The vault is on an external drive. We’ve successfully imported a bunch of photos from Apple Photos. We’ve connected Mylio with her iPhone and they have done a substantial amount of syncing although they are not currently in synch.

Recently Mylio began crashing about 10-15 seconds after launch. It displays photos, it appears to start syncing (or at least displays the sync panel), an activity (“Scanning Apple Photos”) shows up in the Activity panel. Then it quits.

There is no message displayed. Nothing in the system logs (searching for “Mylio” or “mylio”).

My niece has filled up her hard drive. My first guess was that Mylio simply needed space it couldn’t get. But we eventually got space freed; no change. Ran disk utility’s “First Aid”. Everything checks out and Mylio still crashes.



Hi @bwbecker,
You could try to start Mylio in safe mode maybe or at least with the support options so you can maybe send the logs to the Mylio support team for answers.

Here is a link explaining how to start Mylio with support right from start. (press CMD while starting Mylio)

@bwbecker was this solved now?
I have had a similar issue where Mylio just right away quite after start. A catalog repair did the trick for me.

Thanks for the tips, @LucLL. It’s a slower process since it’s not my machine – I have to wait to get together with my niece to see what works.

The article on Support Options was very helpful. Opening in Safe Mode avoided the crashing, but rebuilding the index did not solve the problem. Eventually needed to use the reset option. Now seems to be working OK. Although I’m not sure how this was different from simply uninstalling and then reinstalling Mylio.

1 Like

@bwbecker, thanks for sharing what resolved it. Glad you have it working now. Probably some settings remained with the reinstall somehow.


I am running into the same issue. The reset option solved it but it came back after a few hours.

It seems that the issue is related to face recognition. Once I disabled it entirely (by opening Mylio and quickly going in the settings, advanced section, before it crashes) it worked again normally.

I am therefore left without face recognition. This issue is nearly one year old, I hope someone can look at it… I can send logs if needed.

Open a support ticket with Mylio (

1 Like

I can confirm that this is caused by the face recognition feature. Had the same issue as mentioned above, but only disabling face recognition solved the crashes. I’m pretty sure that this was introduced with the last major update, because it was never an issue before. Even the overall performance seems to be a lot better now with face reognition turned off

I also have this issue. Mylio quits with no explaination.

Maybe this info can help the Mylio Team: when using the non-Windows-Store version of Mylio (Mylio_x64 executable), I have no issue - so it seems to be related to the new way Mylio is installed / executed (UWP?)