Syncing devices via personal hotspot

When I‘m traveling, I occasionally have only cellular connection for some time. Still want to sync devices I have with me (iPhone, iPad, MacBook) to do culling and editing with external editors.

Well I can setup my iPhone as a personal hotspot and connect other iOS devices or Macs to the hotspot via WLAN.

Tried it but Mylio didn‘t sync via peer to peer connection over the hotspot WLAN network.

It did work, if I enabled “sync using cellular” on the iPhone, something I was hesitant to do.

I assume Mylio needs to connect to the Mylio server to initiate the syncing. What I do not know is, whether the actual transfer of the pictures and videos is done over cellular as well (which would be bad) or if Mylio is only using cellular to setup the syncing but the actual data transfer is done via peer to peer connection over the hotspot WLAN.

Does anyone have a definite answer?

A tutorial how to sync devices without having an internet connection would helpful as well in case this is possible technically.

Have you seen this?

Mylio can create an ad hoc network that devices can sync through without the Internet. Look for “Limited Hotspot” in the linked article above or follow the steps below.

From a computer:

  1. Open Mylio.
  2. Navigate to Settings > Sync > Hotspot.
  3. Select Limited Hotspot.
  4. Turn on Limited Hotspot.
  5. Mylio will display a password in a red banner.

Use this passcode to connect other devices to the newly created network to sync.

Thanks, I‘ve read this already.

From the description:

  1. Limited Hotspot
  2. Creates a local ad-hoc network with your computer to sync with another PC or Mac.

I‘ve had the impression, that only other Macs or PCs can connect to this hotspot but no iOS or other mobile devices.

If mobile devices can connect as well, you could add them to that list to make it clear.

So the key is to use the built-in limited hotspot feature in Mylio and not the hotspot feature built into iOS, correct?

The iPhone Personal Hotspot works fine if the phone is connected to the Internet via cellular data. Apple intended this to share that Internet connection with other devices. It’s NOT intended to let those devices connect to each other, however. The iPhone hotspot has “Network Isolation” enabled to prevent this - much like a home Guest network or a hotel//starbucks public hotspot. Mylio, however is clever enough to still allow those devices to sync with each other over the Internet.

I’m actually traveling right now, testing this in my hotel. iPhone is connected to LTE cellular data. Personal Hotspot is turned on, and both my Windows 10 laptop and my iPad are connected to this Personal Hotspot connection. Mylio is running on all three devices, and syncing photos just fine.

I think where the iOS Personal Hotspot does NOT work is when there is no cellular data, say in a remote area. It will generally refuse to even allow connections at all, if your phone doesn’t have an Internet connection. That’s where you need to either use an external wifi travel router, or maybe Mylio’s built-in peer-to-peer hotspot.

If Mylio devices can’t connect to each other directly over the LAN - they will connect to Mylio’s “ICE” servers to negotiate a peer-to-peer connection over the Internet; one that can successfully navigate thru each side’s firewalls. Look up ICE (Internet Connectivity Establishment), specifically the STUN and TURN protocols for details on how this works.

Once the connection is established, the devices send packets directly to each other - without needing Mylio’s servers. Worst case (see TURN) a Mylio server will have to act as an intermediate “packet relay”. This would happen if both devices were on the same network but “Network Isolation” was being enforced - eg, home Guest network, hotel/starbucks hotspot, etc - and unfortunately also in the case of iOS Personal Hotspot. It’ll still work, just slower.

@Mylio_Osiris It does not work for me.

On my MacBook Air M1 I started Mylio went to Settings/Sync/Hotspot and enabled “Limited Hotspot”.
I get a blue box with the text: Your AdHoc name “Mylio-info” is now ready but no red box with a password.
I do not see a hotspot “Mylio-info” to connect to on my iOS devices. And even if it would show up, I won‘t be able to connect without knowing the password.

Have you tried it yourself?

Maybe it is something special with the M1 plattform but then Mylio needs another solution for hotspot syncing as M1 will soon be the major plattform for Macs.

@Pete and @jimre

Thank you for your responses. I have passed this on to our support and engineering teams. We are currently investigating this as a potential bug on macOS and Windows.

FYI - the password can actually be found under your Notification list (red dot on top). If you have disabled pop up notifications, you will have to look up there for it.

BUT - once the password is entered and other devices connected, Mylio does not sync. It used to - I used this a couple years ago. I have a support ticket / bug open on this.

If you DO have cellular internet - then I strongly suggest you use the Apple iOS Personal Hotspot. Works great but it REQUIRES your phone to have cellular internet.

I‘ve bite the bullet and bought a TP-Link mobile LTE router. Initially I didn‘t plan to even add a sim card because all I wanted to achieve was to make the Mylio apps running on macOS and iOS sync via the WLAN and according to the Mylio support articles no internet connection would be necessary.

Well it didn‘t work either. Even though I was able to ping the devices via the WLAN, on Mylio dashboard they showed as offline and no sync happened.

I had to install the sim card from my phone into the TP-Link and then the Mylio apps were able to see each other.

While it works that way, for me this is not an ideal solution. I need the sim card in my phone and do not want to purchachse another one only to make Mylio see other instances via WLAN.

Plus I need to disable a ton of other cloud update services like iCloud or Dropbox that otherwise start their syncing the second the TP-Link router connects to the internet via LTE.

So the whole Mylio experience when traveling is not what I‘ve expected.

Ideally devices running Mylio and logged into the same account should be able to detect each other maybe with the help of bluetooth and setup a local WiFi network without further manual setup needed and start syncing. As a fallback they could use bluetooth in case the WLAN network cannot be established.

If Mylio doesn‘t improve in that area, I‘ll have to look elsewhere for a solution while traveling.

I agree, it is the easiest to setup and it works but pictures are uploaded and downloaded over the internet which can quickly eat up your data volume that is often quite small especially if you are traveling abroad.

It’s been a couple years, but I’ve successfully used a CamRanger (original version) device for this in the past. This is essentially a re-branded TP-Link router with photography-specific firmware, designed for phone-to-camera control over wi-fi. But it worked for a small network of Mylio devices, completely offline - no cellular, SIM card, or Internet.

(I no longer use the CamRanger since my newer cameras all have built-in wi-fi remote control).

Another thought - assuming you have iOS devices here - try disabling “Private Address” in the wi-fi network settings for this network. This is a new “feature” of iOS 14 that can screw up some wi-fi functions, especially with peer-to-peer stuff.

That’s exactly what Mylio’s built-in “Limited Hotspot” feature is supposed to do (minus the bluetooth stuff). But unfortunately it seems to be broken in the current Mac/Windows version of Mylio - they need to fix this.

EDIT: I wonder if the bug we’re seeing with Mylio’s Limited Hotspot is that same thing you’re seeing with the TP-Link? Same symptoms - when I enable the Mylio hotspot, the devices can also Ping each other - but the Mylio apps never connect & start syncing. They only seem to connect when there’s an Internet connection. FYI - @Mylio_Osiris

@jimre If you are currently at home or somewhere you have a working Mylio sync environment via LAN/WLAN, you could do a test and pull the connection to your modem or router and check whether the devices in the Mylio dashboard change to offline. That would be the definite test that Mylio needs a working internet connection (likely to the Mylio servers) for the syncing to work contrary to what Mylio manual is saying. @Mylio_Osiris

Well I know their Limited Hotspot USED to work properly. I’ve used it (a couple years ago) to sync photos between phone & laptop while completely offline in a remote wilderness area, no internet at all. Something seems to have changed or broken in the Mylio Mac/Windows hotspot code. Or possibly something has changed in one or more client operating systems (iOS, MacOS, or Windows) that’s now preventing it from working.

Actually - here’s my “Jim knows just enough to be dangerous” speculation about what’s causing this problem:

In iOS 14, Apple added additional security privileges for which applications must request explicit permission - including the Bonjour auto-discovery service for local networks. And Bonjour happens to be what Mylio uses for local network discovery & connection between devices. I’m guessing maybe Mylio hasn’t added the required permissions-request for iOS 14 and later? And therefore any local connection to an iOS 14+ device is failing?

If I had a 2nd Windows machine with me, I could test this theory by eliminating any iOS devices. Unfortunately I’m traveling this week with one Windows laptop, an iPhone, and an iPad. So any of my local hotspot connections will involve at least one iOS device.

Same with me 1 macOS device and 3 iOS devices. For further tests have to wait until we are back.
Hopefully Mylio engineers then have fixed the issue already.

Seems other apps suffer from these changes as well. Found reports that on iOS14 apps relying on bonjour auto-discovery now need additional entries in the info.plist file to work. @Mylio_Osiris

Surprising discovery…

Today I had my MacBook Air M1 connected via WLAN to my iPad LTE hotspot. Imported some pictures into Mylio.
Connected my iPhone 11 to the iPad LTE hotspot as well because cellular signal was weak on the iPhone. Opened Mylio on the iPhone to search for some older pictures and to my surprise the pictures I had just imported on the MacBook showed up on the iPhone. So Mylio somehow synced the pictures via the iPad hotspot.
I thought clients to iPhone hotspots would be isolated from each other.
I opened Mylio on the iPad as well and though it showed as online as well in devices no syncing started. I then created the hotspot on the iPhone and connected both the MacBook and the iPad to that hotspot and the iPad immediately synced.
So it seems devices sync when connected to the same iOS hotspot with the exception of the device providing the hotspot.
I have limited testing capabilities currently so this is only a preliminary result but maybe it helps Mylio engineers to improve local syncing while traveling.

They are - but since you’re using an LTE hotspot with Internet connectivity, the Mylio devices are likely connecting to each other over the Internet via a Mylio “relay” server, not directly to each other over the local network.

EDIT: UPDATE: see post below. iOS Personal Hotspot apparently DOES allow at least some direct LAN communication between devices.

If you look in the Mylio Sync panel, you can tell the type of connection being used. Devices connected via the Internet will have a tiny little globe symbol:
image

LAN connections will have a small “link/chain” symbol:
image

If you hover your mouse over the device icon in this panel, it should also show a description of the connection type, eg “Connected via Relay” or “Connected via LAN”.