Videos - green thumbnail in folder view

Recently, maybe since the latest update, when viewing folders of items, some videos are green. You can see from the screenshot that these 2 are like this but one below is not, when you view the video itself it plays correctly. The videos are all imported from either my iPhone 11 Pro Max or my wife’s 11 and taken over the last few days. Any help appreciated

You might need to rebuild the previews for those videos. If you’re comfortable using the Console, you can select the images you want to rebuild previews for and use the reparseimages selected command. Or just reach out to support and have them help you.

Interesting one, I ran that on the selected movie and even tried multiples. It didn’t resolve the issue and comes back as Found Matching Image which to me means it hasn’t rebuilt, it just found the existing preview?

Is there a force preview rebuild command?

Would be good to have a repository for the scripts, as they are so useful for specific things like this!

Cheers

Ahh just had a hunt through console commands and ran (didn’t work without the apply after)

reparseimages selected force apply

Worked a treat! Thanks for your help

Glad to hear it!

I had the same and this helped me as well. Thank you!

EDIT: I spoke too soon. Some video refuse to change. I see them update with a momentary image and them they flip back to a green thumbnail.

You could try this console command for the thumbnails:

clearthumb selected

If this does not help - I had once the same green thumbs. I exported the files, deleted them from Mylio and then re-imported the files.

That did not work either but I solved it with help from support. Turns out one of my vaults had hit its quota limits and I adjusted the setting the wrong way to correct so effectively switching off syncing to one vault.

It turns out that if one vault can’t sync then Mylio will stop updating even if there is room on other vaults. Once I corrected this, my green thumbnails corrected.

1 Like

Thanks for telling us how it was resolved, @Kerry! That’s very useful to know.

I have run into this issue today as well. I have hundreds of videos from iPhone 11 and 12 that have green thumbnails and while using the console to force the re-parse works - wondering if this will keep happening. I had to select all of my picture and force the update and it takes a while to fix. Is this an issue that Mylio will fix?

I have the same problem on both my iPhones 11pro max.
The recommended commands don’t work:
clearthumb selected
reparseimages selected force apply

I also have this problem and it seems quite random. I add 10 videos to a folder, maybe half of them will get a thumbnail, the rest don’t. Currently there are quite a number still showing green.

I’ve tried both of the options above. reparseimages selected force apply worked for the first one I tried it for, but not for any others :frowning:

I did have one vault filled up recently but that was after this problem was already occurring. Not sure what to try next.

Ran the reparseimages selected force apply across all 267 videos that I have. Some had good thumbnails, some didn’t. Now some that were good are now green! I can’t see that any green ones came good. Sigh!

Which OS version are you on? For me the issue happened on my OS X Sierra 10.12 device (and remained even after the upgrade to High Sierra 10.13).
Now that I no longer use that device (as the recent Mylio upgrade discontinued support for 10.13), I’ve not (knock on wood) see this happen again.

Fixing the green thumbnails was really painful and labor intensive as it needs to be done on each device separately once the green thumbs have spread across other devices. And key is to run any of the commands only on videos showing a green thumb, otherwise you risk corrupting the thumbs from videos that were fine before). That also means you constantly have to look through your selected video and deselect the ones that were fixed.

Be sure to not select all the videos at first. Give it a try with maybe 30-50 to see how it goes. To have all of the selected videos in view at once, you can adjust the zoom slider in the bottom right. That’s really handy as you’ll need to check all selected videos all the time to deselect the ones fixed.

So here’s basically what I’ve done:

  1. download originals to device (selecting videos > right click on one of them > download original)
  2. set logging to maximum to avoid race conditions (as shown in “sending full logs”)
  3. in console type:
    clearthumb selected
  4. wait for some time (until log mesages in console seem to settle to normal level). Then run this command:
    reparseimages selected apply
  5. again wait for log messages to settle to normal level and scroll through your selection to deselect the ones that are fixed (CTRL/CMD click on them to deselect while keeping the remaining selection)
  6. repeat step 4+5. maybe 10 times and if you don’t see any process anymore, try switching to this command:
    reparseimages selected apply force
    again deselecting all the ones that processed before running it again.
  7. once done, bring back the logging levels in the console back to normal

In case you can’t seem to make any progress (I don’t know why the commands work so badly on doing what seems to be their job), you may have to try the command from step 4 OR step 5 two or three times in quick succession without waiting for log messages to settle to normal. You can easily repeat a command by using the UP arrow key to bring up the previously run command. You can also press UP multiple times to go back in your command history avoiding you to retype the commands.

If you can’t get further, it also may help to select more videos (don’t forget to first download originals to the device and running clearthumb from step 3 on them).

Another thing to try is:
clearthumb selected force
followed by steps 4 to 6. Again, key is to deselect the ones that processed so yu don’t lose them again.

The whole thing is really an ordeal that for many hundred corrupted videos took me easily 2 or more hours per device.

On touch devices it works very similar, except that you can’t use the range select option as doing so wouldn’t be able to deselect individual videos. So you literally have to select each video manually.
And keep in mind that you have to do the open the console before selecting videos as once you’ve selected an item the console can’t be opened anymore.

Good luck!

Hi there and thanks for your detailed explanation of the ‘fix’ (aka workaround). Other than closely resembling that state of idiocy in which one repeats the same actions expecting different results to occur, it worked… eventually!! Very hard to know what on earth is happening, and why random ones would work and others not. Some had to be ‘hit’ well over 10 times before yielding.

I am on Catalina on a MacBook 12 (2015), a vault, and that took ages to correct them. I have another vault on a Mac Mini M1 (nice!) and only had to apply the commands once to get the changes (with a few exceptions that yielded on the second attempt).

I also have 2 iPhones and an iPad that needed to be updated, and other than overlooking the need to download the originals (which took most of the time) they all responded OK.

What a business!!! I sincerely hope they won’t return any time soon…

With thanks again. Your assistance is greatly appreciated.

1 Like

Glad to hear it helped you! Yeah, while fixing this on my own devices, I’ve voiced quite a few swearwords / complaints at having to repeatedly run these commands over and over to just see one or two videos get fixed at a time. And then often times a few reverted back to green still.

Do you have any idea from what time your green thumbs were and what OS X you were on at that time? Mine were from imports starting in Aug or Sep 2020 and continued all the way until Feb 2021. They only occurred for videos that were imported through my Sierra / High Sierra machine. Imports done via my Mojave or now the Win 10 virtual machine on my NAS were fine so far. That leads me to believe this was an issue limited to Sierra / High Sierra.

Hi @rain. The videos were imported on a machine running High Sierra as I’m working on exporting all photos from Apple Photos to Mylio. I have a new Mac Mini and had planned to use that to do the photo exports but unfortunately Photos has a range of new bugs on Big Sur (largely inherited from Catalina) that would have made that process very difficult. Not least in some scenarios not exporting metadata consistently. So… that left me exporting from my old slow late 2009 iMac (grrr). They would have been transferred over the Feb and March timeframe.

Hopefully now that all my videos are over, the problem will settle :slight_smile:

PS Movjave is FINE for Apple Photos but Catalina and Big Sur have caused a huge number of issues, faces recalculated/reassigned, photos unable to be exported and giving errors (all exported fine in Mojave), exported photos losing metadata etc etc Seriously wish I’d stayed on Mojave but perhaps the horrors of Catalina were needed to push me over the line and fully into Mylio.

@Mylio_Michael Would you mind giving the steps I listed a try on a bunch of test videos on your end if you can reproduce the the “reparseimages selected apply” command to result in some green thumbnails?
While the import to result in green video thumbnails for me seems to be limited to videos imported on OS X Sierra / High Sierra, this doesn’t explain why the commands to repair may return the videos into a green thumbnail state unless deselected. Or why I had to increase the log levels all the way to be able to get any progress on fixing this in the first place.
In my exchange with you and Matthew via email on this (“Re: green / corrupted thumbs on videos since Oct 17”) I also sent you a video on Dec 19 2020 (via the in app reporting feature) of a video thumbnail repeatedly reverting to green.

Seeing that others like @mpitman have the same problem I have and have to go through really idiotic steps trying to hammer in a fix, I really think there’s some underlying issue with those commands supposed to make it easy to fix such problems.

Thanks for looking into this again.

1 Like

We have a fix coming soon for this issue to prevent it from happening and are working on a way to regenerate thumbs/previews more easily down the road. We know this issue has affected a number of Mac users and do apologize.

After the next update is released, re-importing the videos should result in the correct thumbnail generation.

Alternatively, when the release comes out you can turn off sync in Settings->Sync, and then run ‘reparseimagse selected force apply’ and ‘clearthumb’ with the affected videos selected but will need to run this command on all devices to avoid the incorrect previews from getting synced back.

This can get a little complicated, like running the command for USB drives, NAS, and cloud services (which we do need to do). For these devices the command can be ran from connected computer using `reparseimages selected force apply device_id ’ where the device id number can be found in the console. Obviously this can get a little tricky so please feel free to contact support via the in-app Help option and we can send specific instructions to each user with the correct device id numbers.

Thanks @Mylio_Michael it’s good to know a fix is on the way. In the meantime my larger than life game of whack-a-mole seems to be holding… fingers crossed :slight_smile: